That's Pretty Cool

Certificate issues

Resolved
API Staff Services
Degraded Performance

This case has been assigned the engineer: Brendan T. David Jennings (1)

Some backend issues are causing the incorrect certificate to be provided to users. We are working on resolving this issue now.

2019-11-12T22:33:50.100Z
Resolved

Problem with our ssl validation server providing the incorrect certificates.

Issue has now been resolved.