That's Pretty Cool

Billing down

Resolved
Billing server
Partial Outage

Users are unable to access the billing portal. Payments may still be processed and management is still available. We are investigating the issue and will restore the service as fast as possible.

2019-12-07T23:07:00.000Z
Update

The billing platform will be unavailable until tomorrow. We apologise for any inconvenience this may cause, feel free to call us on +44 7464 287113 to discuss anything billing related!

This has been escalated to a major outage

2019-12-08T16:24:00.000Z
Update (2)

Billing backend has been restored. Payment management has been restored. We are working to restore the front-end for our clients.

This has been de-escalated to partial outage.

2019-12-08T22:57:00.000Z
Resolved

All billing services have been restored to normal, you can go ahead and check out the billing dashboard here