That's Pretty Cool

GCP us-east1

Resolved
Site Delivery
Degraded Performance

Some users who are reliant on GCP and do not pay for redundancy may see service instability and extremely poor performance. This is not in our control, please monitor GCP status here

2019-12-07T21:04:00.000Z
Resolved

All the previously identified users who were affected by this issue are no longer being effected.